Author Topic: Options :: Document Defaults -> Encoding not work!  (Read 1154 times)

ntmywzc

  • Guest
Options :: Document Defaults -> Encoding not work!
« on: July 16, 2009, 06:13:16 am »
For Example:
I changed "Document Defaults -> Encoding" from "Automatic" to "Unicode(1200)".

But everytime I open a exists file from File Explorer or Drag from Windows Explorer,
HippoEdit ALWAYS automatic change the Encoding to "1252"(shown in Status Bar).


The right way is :
When I set "Document Defaults -> Encoding" from "Automatic" to "Unicode(1200)".
HippoEdit must always open every file in the  Encoding "Unicode(1200)".

« Last Edit: July 16, 2009, 06:17:30 am by ntmywzc »

Offline alex

  • Developer
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2181
  • Karma: +37/-3
    • View Profile
    • HippoEDIT
Re: Options :: Document Defaults -> Encoding not work!
« Reply #1 on: July 16, 2009, 10:35:15 am »
Hi ntmywzc :),

welcome.
No, this is not a bug. HippoEDIT works here as designed. Encoding settings from Document default only used for new files.
Here you can find some more details about encoding settings in Hippoedit.

An easy way to open files always as Unicode is to select UTF-16 BE in File Open Dialog explicitly. Then HE would remember this setting between sessions and would always open files as UTF-16 BE.

Best regards,
Alex

 

Related Topics

  Subject / Started by Replies Last post
3 Replies
1929 Views
Last post March 23, 2009, 10:59:15 am
by alex
12 Replies
4482 Views
Last post April 25, 2009, 03:23:48 pm
by allen
1 Replies
1302 Views
Last post February 29, 2012, 10:02:02 pm
by alex
6 Replies
2159 Views
Last post September 18, 2014, 02:24:45 pm
by Andreas
3 Replies
1102 Views
Last post May 19, 2015, 05:55:10 pm
by alex