Author Topic: how to let HippoEDIT not make *.xml when I edit file  (Read 3549 times)

Offline false007

  • Registered User
  • Jr. Member
  • *
  • Posts: 60
  • Karma: +0/-0
    • View Profile
how to let HippoEDIT not make *.xml when I edit file
« on: September 20, 2010, 04:46:35 am »
when I edit file (such as .php,.shml), HippoEDIT will make a file xml file.

I don't want to make the xml file, how should I config the HippoEDIT???

Offline Stefan

  • Administrator
  • Hero Member
  • *****
  • Posts: 775
  • Karma: +6/-0
    • View Profile
Re: how to let HippoEDIT not make *.xml when I edit file
« Reply #1 on: September 20, 2010, 07:04:48 am »
I think "Tools > Options... > Editor || General | [X] Save Auto-Recovery information" is related?

or was it " [X] Retain Undo After Save" ?

Offline false007

  • Registered User
  • Jr. Member
  • *
  • Posts: 60
  • Karma: +0/-0
    • View Profile
Re: how to let HippoEDIT not make *.xml when I edit file
« Reply #2 on: September 21, 2010, 02:46:22 am »
see this example:

I edit Account.php this file, and HE make a file like Account.php.inf.xml.

    eg:     homepage.js, homepage.js.inf.xml
« Last Edit: September 21, 2010, 03:19:23 am by false007 »

Offline alex

  • Developer
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2181
  • Karma: +37/-3
    • View Profile
    • HippoEDIT
Re: how to let HippoEDIT not make *.xml when I edit file
« Reply #3 on: September 21, 2010, 11:19:30 pm »
Hi false007,

the xml files you mean, are files satellites. These files contain document related information, which is not possible to save inside of the file, as:
- cursor, selection etc position
- Bookmarks information
- Breakpoint information
- Protected areas information
- Outlining state
- User text highlights (only for 1.50)

Generally for 1.4x is only bookmark and folding information are relevant, because only existing of them leads to creation of such satellite file, by default (this mean if you st a bookmark or collapse some block this will lead to creation of file). Position information not leads to creating of such file, but stored inside, if file exist.

If you do not like such behavior, you can disable bookmark + folding state persistence. For this there are several xml flags exist.

change file data\settings.xml
Code: [Select]
<General>
<Persist bookmarks="false" folding="false" user_blocks="false" breakpoints="false" protected="false" positions="true"/>
</General>

Best regards,
Alex
P.S: checking the code, found out, that there is maybe bug, and files will be created any way (even if bookmark information is not saved). If this like it is, this is a bug and will be fixed in new beta 1.49.

Offline Arthur

  • Registered User
  • Hero Member
  • *
  • Posts: 653
  • Karma: +1/-0
  • He who is ashamed of asking is afraid of learning.
    • View Profile
    • My Blog
Re: how to let HippoEDIT not make *.xml when I edit file
« Reply #4 on: September 22, 2010, 08:38:56 pm »
Just an idea: perhaps no satellite files should be used. How about using special folders? HippoEdit is already in say %USERPROFILE%\Application Data.
Besides, I see .tmp file is cerated in the same directory each time I open a file for editing, this is not desirable under some circumstances.

Offline alex

  • Developer
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2181
  • Karma: +37/-3
    • View Profile
    • HippoEDIT
Re: how to let HippoEDIT not make *.xml when I edit file
« Reply #5 on: September 23, 2010, 12:18:34 am »
Hi Arthur,

this was already discussed here (topic is started by you ;) ).
Briefly, this can an option, but than you will not be able to move bookmarks together with file.

Temp files are probably auto recovery information or backup. Auto-Recovery files normally deleted after you save file or close it without save. Both option can be disabled.

Best regards,
Alex.

Offline false007

  • Registered User
  • Jr. Member
  • *
  • Posts: 60
  • Karma: +0/-0
    • View Profile
Re: how to let HippoEDIT not make *.xml when I edit file
« Reply #6 on: September 26, 2010, 02:26:56 am »
@@Alex
very thanks.

change file data\settings.xml
Code: [Select]
<General>
<Persist bookmarks="false" folding="false" user_blocks="false" breakpoints="false" protected="false" positions="true"/>
</General>

 

Related Topics

  Subject / Started by Replies Last post
1 Replies
2149 Views
Last post March 19, 2009, 08:40:00 pm
by alex
3 Replies
2149 Views
Last post September 15, 2009, 07:29:11 pm
by alex
0 Replies
3242 Views
Last post December 11, 2008, 09:16:37 am
by Stefan
2 Replies
3264 Views
Last post October 20, 2010, 07:30:48 pm
by alex
2 Replies
1946 Views
Last post July 05, 2012, 03:20:51 pm
by false007