Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Andreas

Pages: [1] 2 3 4
1
Feature requests and suggestions / Re: Vertical line density
« on: January 12, 2015, 05:31:48 pm »
Hi Alex,

is it possible that the additional space which HippoEdit puts between lines is due to the current line frame? I don't use the current line frame anyway (have set its color to 'transparent', but it still seems to be there, even if it's invisible). Would it help to turn it completely off? In the Wiki, an XML setting "Show Current Line Frame" is mentioned, but it's not clear to me whether this setting actually exists.

Best regards,
Andreas

2
Feature requests and suggestions / Re: Vertical line density
« on: January 06, 2015, 11:40:49 pm »
Hi Alex,

I'm using Consolas, 10pt as my coding font. When I set the Line Spacing to "Exactly, 9pt" in HippoEdit, then the descenders of lowercase letters like g, j, p, q, and y will be cut off, which is not acceptable of course. And when I set the Line Spacing to "Exactly, 10pt", then the letters will be displayed correctly (descenders not cut off), but the line spacing will be bigger than in EditPad Pro and EmEditor. So it seems to be impossible in HippoEdit to display as many lines per vertical space as in EditPad Pro or EmEditor. :(

Best regards,
Andreas

3
Feature requests and suggestions / Vertical line density
« on: January 06, 2015, 12:12:55 pm »
Hi Alex,

EditPad Pro and EmEditor display a few more lines in the editor pane than HippoEdit, even if the font, the font size, and the editor pane size are exactly the same. HippoEdit seems to add one or two pixels of empty space between the lines. Would it be possible to turn off that behaviour?

Best regards,
Andreas

4
But I will check that can be done.

Hi Alex,

apparently you have managed to fulfill my wish in v1.60.7 (although this change is not listed in your "HippoEDIT 1.60.7 released" posting.) Thank you very much for that!

Best regards,
Andreas

5
Bug reports / Re: Undesired lock on folder
« on: December 15, 2014, 02:36:12 pm »
Hi Alex,

yes, with File Explorer it does work correctly.

It's not a big problem. I can live with it. I only wonder why this problem does not occur with other editors, e.g. EditPad Pro or EmEditor.

Best regards,
Andreas

6
Bug reports / Undesired lock on folder
« on: December 15, 2014, 12:20:18 pm »
Hi Alex,

in the following scenario, HippoEdit keeps an undesired lock on a folder:

1. Disable the option 'Keep files locked while editing them' in HippoEdit.
2. Create a directory.
3. Copy a text file into the directory.
4. Open the text file in HippoEdit.
5. Close the text file in HippoEdit, but keep HippoEdit running.
6. Delete the file.

After these five steps, the directory cannot be deleted although it is empty. Windows Explorer says: "The action can't be completed because the folder or a file in it is open in another program. Close the folder or file and try again." The folder can only be deleted after closing HippoEdit.

Best regards,
Andreas

7
Hi Alex,

it seems that in v1.60.6 the documents are now sorted by reverse activation sequence. That's not exactly what I wanted. I wanted that the documents are sorted by tab order, i.e. the topmost entry in the list should be the leftmost tab.

Best regards,
Andreas

8
Bug reports / Re: Behavior of View.SearchOutput
« on: December 13, 2014, 11:19:58 pm »
Hi Alex,

thank you very much. By the way, in the Tool Properties dialog, when you remove the checkmark from the option 'Show in toolbar' and then click OK and then click OK again in the Manage Tools dialog, HippoEdit will crash.

Best regards,
Andreas

9
Hi Alex,

would it be sufficient that on initial display documents appears "unsorted" (sorted by tab order) but not sorted by name?

Yes, that would be sufficient.


Actually there is window order - one used when you press Ctrl+Tab (sorted by activation sequence) and document tab order (how you see them in tab bar). Which order you mean?

I mean tab order (how you see them in tab bar).


I would prefer to satisfy you with minimal effort on my side :)

That's clear. :)Thank you very much.

Best regards,
Andreas

10
Bug reports / Re: Behavior of View.SearchOutput
« on: December 08, 2014, 07:59:50 pm »
  • If you execute command within the pane, it will bring you back to active text editor.

Okay, but that doesn't help me, because I want to close the Find Results pane and not just put the focus to the text editor.


- if you create tool script, you can call it as any tool for syntax (Tools->Manage Tools). There is an option to assign a shortcut for tool.

Perfect! I will do that (as soon as it's possible to retrieve the pane state.)

Thank you.

11
Feature requests and suggestions / Sort order in window management dialog
« on: December 07, 2014, 12:30:32 pm »
I have the following wishes:

1. In the window management dialog (Window -> Windows), I would like to be able to sort the entries in tab order, i.e. the leftmost tab should be the topmost entry in the list.

2. The window management dialog should remember the sorting criterion chosen by the user. (Currently, when you open the window management dialog, the entries will always be sorted alphabetically by name.)

12
Bug reports / Re: Behavior of View.SearchOutput
« on: December 07, 2014, 12:14:42 pm »
Currently I have two keyboard shortcuts for the Find Results pane: One to open it and another one to close it. But this is difficult to remember. Therefore, I would prefer one single keyboard shortcut which toggles the visibility of the Find Results pane. If the Find Results pane is open, pressing the key shall close it, and if Find Results pane is closed, pressing the key shall open it. I have tried to write a script for that purpose, but I ran into the following problems:

1. It seems to be impossible to determine in a script whether the Find Results pane is currently open or closed.
2. It seems to be impossible to assign a keyboard shortcut to a script (so that the script will be executed when the key is pressed).

Can these problems be solved somehow?

Alternatively, a new command which simply toggles the visibility of the Find Results pane would make things much easier.

13
Bug reports / Re: Closing parenthesis ")" not added
« on: November 08, 2014, 08:41:45 am »
Hi Alex,

there is still a problem here. To reproduce it, make sure that the Auto-Brackets option is disabled. Then copy the following line of code into a C++ source file in HippoEdit:

    int a = b * (c + d * func);

Now place the cursor onto the closing parenthesis ")" and then quickly type "(" and ")".

As a result, the closing parenthesis ")" you have just entered will NOT be added to the code.

The problem will not occur when you slowly type "(" and ")".

Best regards,
Andreas

14
Hi Alex,

actually I have also tried that with HippoEDIT before posting on Terminal server. And it has an effect.

I have tried it again, and now it does work for me too. I have a blinking cursor in HippoEdit during remote desktop connection! I'm not sure why it didn't work the first time. Maybe after applying the registry change, you must log off from the remote PC and then log on again. That's the only difference I'm aware of between my first try and my second try. Anyway: Problem solved! Thank you very much for your effort.


I am using the system caret for drawing cursor, that is controlled by OS. And I see that as nice, that behavior in HE is in sync with the rest of standard app running in terminal server session.

I agree.


Best regards,
Andreas

15
http://discussions.citrix.com/topic/91571-cursor-doesnt-show-or-blink-in-published-apps/#entry623603

I have tried that. It does work for Microsoft Office, i.e. with the described registry change, the cursor in Microsoft Word and Outlook does blink. But unfortunately, the cursor in HippoEdit still doesn't blink.

Pages: [1] 2 3 4