HippoEDIT - Programmers text editor

Русская Поддержка - Russian Support => Общие вопросы => Topic started by: AlexLPR on January 10, 2018, 08:25:28 am

Title: Дублирование символов при вставке из Template
Post by: AlexLPR on January 10, 2018, 08:25:28 am
Добрый день. Не знаю, как это работает в других лексерах, на при использовании Tempate в Cliper_user.xml происходит задвоение символов. Например, применение
   <Tempate key="xy" descr="Test">Any text\n</Template>  дает AAnnyy  tteexxtt

PS. версия 1.60.46 Non Unicode
Title: Re: Дублирование символов при вставке из Template
Post by: alex on January 11, 2018, 02:12:57 am
Привет,

думал, это только специфика не юникодовой версии (я и не думал, что ее еще используют, особенно если не ангоязычные), но нет - у меня все работает без проблем.
В обеих версиях. Пример один в один? Может там в коде русский текст?

C уважением,
Алекс.
Title: Re: Дублирование символов при вставке из Template
Post by: AlexLPR on January 11, 2018, 10:19:47 am
Пример приведен точно. Русских символов нет. Может быть, причина в портативной версии? Или лучше перейти на Юникодную?
Title: Re: Дублирование символов при вставке из Template
Post by: AlexLPR on January 11, 2018, 06:03:42 pm
Попробовал тот же пример в портативной юникодной версии - все ОК. Вопрос можно считать закрытым.
Title: Re: Дублирование символов при вставке из Template
Post by: alex on January 11, 2018, 08:45:46 pm
Хорошо, конечно, что теперь все Ок, но я воспроизвести так и не смог.
Не думаю, что это связано с архитектурой или вариантом установки.
Скорее всего это какой то HippoEDIT планиг/скрипт запускается или внешняя тулза.