Author Topic: [Solved] Data Loss  (Read 292 times)

Offline HippoKondriaq

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
[Solved] Data Loss
« on: January 20, 2017, 06:00:40 am »
How to reproduce:
  • Start Microsoft Notepad.
  • Type the following text into an empty file: ABC123
  • Save the file as test.txt.
    Make sure that Encoding is set to ANSI.
  • Open test.txt with HippoEDIT.
    In my case, the Document Encoding of the file is identified as 20127 (US-ASCII).
  • Enter (horizontal ellipsis) after ABC123 by typing Alt+0133.
  • Hit Ctrl+S to save the file.
    The following message pops up:
    Quote from: HippoEDIT (Document Encoding Wrong)
    Some Unicode characters in this document could not be saved in the current codepage.
    Do you want to re-save this document as Unicode in order to maintain your data?

    [Yes] [No] [Save With Other Encoding] [Cancel]

    [  ] Don't ask me again (always use selected)
  • Select Cancel.
    Using your file manager, you'll observe that text.txt disappears and test.txt.auto.tmp shows up.
  • Press Ctrl+Z to undo the changes you made to text.txt.
  • Close test.txt.
    test.txt.auto.tmp is deleted.

HippoEDIT v1.60.34 (hippou160.exe)
Windows XP Professional SP3 (v5.1.2600) English
Active code page: 437 (United States)
Intel Core 2 Duo E7500 @ 2.93GHz
« Last Edit: January 31, 2017, 02:00:45 am by HippoKondriaq »

Offline alex

  • Developer
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2154
  • Karma: +37/-3
    • View Profile
    • HippoEDIT
Re: Data Loss
« Reply #1 on: January 23, 2017, 01:40:13 am »
Hi,

Cool ;) I have mostly reproduced it.

I was not able to get 20127 as auto detected code page for the new file - in my case, it was my default code page. But the issue with auto detection encoding may occur - there are too less data for proper detection. But one can always select the proper one in the status bar, or in file open dialog.

So, if you type Unicode symbol, that is not presented in current encoding, the popup for extended save was OK.
But lost original file after Cancel - is an ugly bug. I will fix it in next build.

The *.auto.tmp file is OK - it is auto recovery information. It exists, when unsaved data exist and deleted after save.

Thanks for great scenario description!

Best regards,
Alex.

Offline HippoKondriaq

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: Data Loss
« Reply #2 on: January 25, 2017, 01:00:36 am »
Thanks for looking into this, Alex! I'll report back as soon as the new release is available.

I was not able to get 20127 as auto detected code page for the new file - in my case, it was my default code page. But the issue with auto detection encoding may occur - there are too less data for proper detection. But one can always select the proper one in the status bar, or in file open dialog.

So, if you type Unicode symbol, that is not presented in current encoding, the popup for extended save was OK.
But lost original file after Cancel - is an ugly bug. I will fix it in next build.

The *.auto.tmp file is OK - it is auto recovery information. It exists, when unsaved data exist and deleted after save.

Exactly, the deletion of both test.txt and test.txt.auto.tmp is the only bug. Everything else works as expected. I just wanted to give you as much info as possible.

PS: I'm attaching a sample file (test.reg) just in case.
« Last Edit: January 25, 2017, 01:30:51 am by HippoKondriaq »

Offline alex

  • Developer
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2154
  • Karma: +37/-3
    • View Profile
    • HippoEDIT
Re: Data Loss
« Reply #3 on: January 25, 2017, 10:38:54 am »
OK, then it is already fixed ;)
I will release new build today/tomorrow, after doing tests.

Offline HippoKondriaq

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: Data Loss
« Reply #4 on: January 31, 2017, 02:15:33 am »
Thanks for the new release and your prompt action in fixing this bug, Alex 8)
« Last Edit: January 31, 2017, 02:30:44 am by HippoKondriaq »

Offline alex

  • Developer
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2154
  • Karma: +37/-3
    • View Profile
    • HippoEDIT
Re: [Solved] Data Loss
« Reply #5 on: January 31, 2017, 10:43:49 am »
NP. I am always happy to fix bugs if I can reproduce them ;)

 

Related Topics

  Subject / Started by Replies Last post
6 Replies
3217 Views
Last post December 04, 2008, 04:06:38 pm
by alex
18 Replies
5321 Views
Last post February 23, 2009, 06:15:27 pm
by alex
4 Replies
1199 Views
Last post March 19, 2009, 02:44:42 pm
by Arthur
4 Replies
1740 Views
Last post April 11, 2009, 12:17:15 pm
by Stefan
3 Replies
2509 Views
Last post February 12, 2011, 04:03:56 pm
by alex