Author Topic: Just updated to new version and now error when starting?  (Read 4153 times)

Raymond

  • Guest
Just updated to new version and now error when starting?
« on: January 11, 2010, 06:31:36 pm »
When I started up HippoEdit a moment ago, I was prompted by a dialog that asked if I wanted to check if there were new updates available...

Well, that sounded good so I said OK...

It went out and did the download, and the install and all went fine UNTIL it tried to run HippoEdit!!!

Now I receive this:
---------------------------
HippoEdit.exe - Entry Point Not Found
---------------------------
The procedure entry point IsWow64Process could not be located in the dynamic link library KERNEL32.dll.
---------------------------
OK   
---------------------------

I am running Win 2000 Pro

Please advise,
-Raymond

Offline Arthur

  • Registered User
  • Hero Member
  • *
  • Posts: 653
  • Karma: +1/-0
  • He who is ashamed of asking is afraid of learning.
    • View Profile
    • My Blog
Re: Just updated to new version and now error when starting?
« Reply #1 on: January 11, 2010, 08:12:30 pm »
Hello Raymond and welcome to the forum.

To me this sounds like a compatibility issue (perhaps the installed version was wrong).

In any case I suggest completely un-installing HE and installing it again preferably using a beta build because it has extended issue reporting capabilities.

Besides, next time please specify HE build/version.

PS: Please report back if that resolved your issue.

Raymond

  • Guest
Re: Just updated to new version and now error when starting?
« Reply #2 on: January 11, 2010, 08:50:56 pm »
Thanks Arthur...

It was ver 1.47 that caused me the trouble...

I uninstalled and then I re-downloaded 1.47 and installed and I ended up with the exact same error message

**notice the IsWow64Process... I know my system is _not_ a 64 bit... :-)

I see there are a few beta builds... is there a particular one that you want me to try???

I will un-install again while I wait for your response.

Thanks,
-Raymond

Offline Arthur

  • Registered User
  • Hero Member
  • *
  • Posts: 653
  • Karma: +1/-0
  • He who is ashamed of asking is afraid of learning.
    • View Profile
    • My Blog
Re: Just updated to new version and now error when starting?
« Reply #3 on: January 11, 2010, 09:02:45 pm »
Please un-install your HE and install from this location (it is not a 64 Bit build):
http://www.hippoedit.com/download/hippou148_pdb.exe
Let me know the end result please.

Raymond

  • Guest
Re: Just updated to new version and now error when starting?
« Reply #4 on: January 11, 2010, 09:14:48 pm »
OK,

I just un-installed and then installed the build for 1.48 and no-go, same error message

---------------------------
HippoEdit.exe - Entry Point Not Found
---------------------------
The procedure entry point IsWow64Process could not be located in the dynamic link library KERNEL32.dll.
---------------------------
OK   
---------------------------

Is there something else (error log, etc) that I should be sending?

Thanks for the help,
-Raymond

Offline Arthur

  • Registered User
  • Hero Member
  • *
  • Posts: 653
  • Karma: +1/-0
  • He who is ashamed of asking is afraid of learning.
    • View Profile
    • My Blog
Re: Just updated to new version and now error when starting?
« Reply #5 on: January 11, 2010, 10:08:31 pm »
Try to unisntall it and download the stable version to try from the front page of HippoEdit.

At the same time I will do some research for your issue.

Please tell me: do you have OpenGL installed? If yes, could you try updating it?
« Last Edit: January 11, 2010, 10:17:42 pm by Arthur »

Offline alex

  • Developer
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2184
  • Karma: +37/-3
    • View Profile
    • HippoEDIT
Re: Just updated to new version and now error when starting?
« Reply #6 on: January 11, 2010, 10:17:02 pm »
Hello Arthur and Raymond,

@Arthur: thanks for a help.

I think this is my fault. I have not checked Unicode build of 1.47 on Windows 2000.
And as far as I see IsWow64Process is only available from XP. This is a reason for the error message.

So what to do: just use Non-Unicode (98/Me) version. If you do not edit texts in different languages you will not see the difference.
Meanwhile I will fix (will add dynamic call for IsWow64Process) the error in next 1.48 beta. Will be available start of the next week.

Best regards,
Alex.

Raymond

  • Guest
Re: Just updated to new version and now error when starting?
« Reply #7 on: January 11, 2010, 10:28:37 pm »
OK, that makes sense.

I can hold off until the next beta version.... and I may even have the old installer that I originally uninstalled too....

Many thanks,
-Raymond

Raymond

  • Guest
Re: Just updated to new version and now error when starting?
« Reply #8 on: January 12, 2010, 03:23:25 am »
OK, I found my old hippou146.exe installer and I am back in business again!!!

I will wait for a bit to install the next ver....  :-)


Thanks for the help though!!!
-Raymond

Offline alex

  • Developer
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2184
  • Karma: +37/-3
    • View Profile
    • HippoEDIT
Re: Just updated to new version and now error when starting?
« Reply #9 on: January 12, 2010, 12:32:45 pm »
Good :). But as I said you can use non-unicode 1.47 also.