Author Topic: Windows7 Settings not saved  (Read 2193 times)

Offline chrislu

  • Registered User
  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Windows7 Settings not saved
« on: October 12, 2009, 10:41:30 am »
Hi,
i noticed after switching to Windows7 (RC and RTM) that my HippoEdit settings were not saved. The problem is that HippoEdit by default tries to save them into the program directory (HippoEdit/data) which can only be written to with explicit administrator rights (new in Windows7 i think). The solution would be to save all the user specific settings data in the users home directory (users/xxx/AppData/Roaming for example). Trying to switch the directory by hand in the HippoEdit settings did not take because the settings were not saved ;).


Offline Stefan

  • Administrator
  • Hero Member
  • *****
  • Posts: 775
  • Karma: +6/-0
    • View Profile
Re: Windows7 Settings not saved
« Reply #1 on: October 12, 2009, 11:10:02 am »
Hi chrislu,

since you have no write access to the HippoEDIT program folder, just Grant Permissions for group USERS too it.

Here is an how to => http://forum.hippoedit.com/index.php/topic,597.msg2683.html#msg2683

Offline alex

  • Developer
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2184
  • Karma: +37/-3
    • View Profile
    • HippoEDIT
Re: Windows7 Settings not saved
« Reply #2 on: October 12, 2009, 11:37:33 am »
Hi chrislu,

yes, this is known problem. Would be fixed like you suggested in 1.50.
Till then use way suggested by Stefan (thanks Stefan) or install HE not inside of Program Files or use 32 bit version of HE (it installed into Program Files (x86) that does not have problem with write rights by default).

Best regards,
Alex.