Author Topic: A UNIX File Shown as Mixed Mode  (Read 2581 times)

Offline Arthur

  • Registered User
  • Hero Member
  • *
  • Posts: 653
  • Karma: +1/-0
  • He who is ashamed of asking is afraid of learning.
    • My Blog
A UNIX File Shown as Mixed Mode
« on: April 20, 2012, 09:37:45 PM »
I suggested a feature http://bit.ly/JdURfR, but it may be very well a defect instead.
Thing is, I can see the line ending is being indicated (not the file type) in the HE's status bar (bottom), but after I opened a UNIX file it does not say UNIX, it says MIXED, however, there is no CRs and CRLFs or LFs and CRLFs in the file (note, Notepad displays it as UNIX).

Offline alex

  • Developer
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2224
  • Karma: +37/-3
    • HippoEDIT
Re: A UNIX File Shown as Mixed Mode
« Reply #1 on: April 23, 2012, 01:46:20 PM »
Hi Arthur,

normally HE does not do has erorrs on line feed determination. And that can happen, that NP++ does not have a mixed mode for display.
You can enable View->Editor->White Space and see, which lines have not a LF endings.

If you can not find this out, send file to me (or attach it here) - I will check.

BR, Alex

Offline Arthur

  • Registered User
  • Hero Member
  • *
  • Posts: 653
  • Karma: +1/-0
  • He who is ashamed of asking is afraid of learning.
    • My Blog
Re: A UNIX File Shown as Mixed Mode
« Reply #2 on: April 24, 2012, 04:08:27 PM »
I made sure before reporting it to search (in RegEx mode) for \r (CR), found none, I can find \n (LFs) on each.
Thus, I am inclined to state it is a bug.
Now when I send you the file directly see if there is even one more bug regarding the 1st line - it does not show the line ending on my end.

Offline alex

  • Developer
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2224
  • Karma: +37/-3
    • HippoEDIT
Re: A UNIX File Shown as Mixed Mode
« Reply #3 on: April 24, 2012, 07:53:43 PM »
Yes - it is a bug :) You are right.
Already checked with your file. Only happens with asynchronosly loaded files, which are not in Windows formats (Windows format inserted by default, when reading files in this case, because of that it is mixed - LF + CRLF).

Will fix with next 1.59 update.