Author Topic: [REQ] Option to set delay before popup  (Read 3917 times)

Offline JJK

  • Registered User
  • Full Member
  • *
  • Posts: 152
  • Karma: +2/-0
[REQ] Option to set delay before popup
« on: November 10, 2008, 05:55:54 PM »
Hello all
I discovered HippoEdit yesterday. It seems great.
Can you add an option to set delay before displaying popup. For example displaying hints or commands are too long for me. Also to display hidden text in outlined section.

TIA
JJK
« Last Edit: January 07, 2009, 03:06:12 PM by alex »

Offline alex

  • Developer
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2190
  • Karma: +37/-3
    • HippoEDIT
Re: [REQ] Option to set delay before popup
« Reply #1 on: November 11, 2008, 12:22:42 PM »
Hello JJK,

It is already possible. But because it is more customizing and interesting mostly for expert users it is not published in Options dialog, but could be changed through xml files.

Check file settings.xml in HippoEDIT data directory (%HIPPOEDIT_DIRECTORY%\data).
<HoveringDelay>1000</HoveringDelay> - value controls delay before showing tooltip (in milliseconds).

Code Hints should be displayed immediatelly.

Delay before hiding of the tooltip can be adjusted in Tools->Options->Code Completion.

Best regards,
Alex.

Offline JJK

  • Registered User
  • Full Member
  • *
  • Posts: 152
  • Karma: +2/-0
Re: [REQ] Option to set delay before popup
« Reply #2 on: November 11, 2008, 10:43:32 PM »
Good ! I hadn't seen those features.
Thanks

Offline JJK

  • Registered User
  • Full Member
  • *
  • Posts: 152
  • Karma: +2/-0
Re: [REQ] Option to set delay before popup
« Reply #3 on: December 09, 2008, 10:39:11 AM »
Quote
Check file settings.xml in HippoEDIT data directory (%HIPPOEDIT_DIRECTORY%\data).
<HoveringDelay>1000</HoveringDelay> - value controls delay before showing tooltip (in milliseconds).
Sorry, but I do no longer find settings.xml in data directory (for version 1.40 beta 550). Instead, there is settings.xslt, but it does not contain holder to set HoveringDelay.
Have I missed anything ?

Offline alex

  • Developer
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2190
  • Karma: +37/-3
    • HippoEDIT
Re: [REQ] Option to set delay before popup
« Reply #4 on: December 09, 2008, 11:02:23 AM »
I think you did reinstall.
Just start Hipooedit once, and then you would get settings.xml created.

Offline JJK

  • Registered User
  • Full Member
  • *
  • Posts: 152
  • Karma: +2/-0
Re: [REQ] Option to set delay before popup
« Reply #5 on: December 09, 2008, 11:20:19 AM »
Quote
I think you did reinstall.
Just start Hipooedit once, and then you would get settings.xml created.
No, I had not reinstalled, and nowhere settings.xml after restarting HE.
Now, I have reinstalled to see. But not yet settings.xml.
Have I to install version 1.33 before installing 1.40 beta ?

Offline Stefan

  • Administrator
  • Hero Member
  • *****
  • Posts: 775
  • Karma: +6/-0
Re: [REQ] Option to set delay before popup
« Reply #6 on: December 09, 2008, 12:26:40 PM »
I have my settings.xml because i have used the same old folder for new beta.

But for testing i have unpackt beta 550 -> no settings.xml
I have started and closed HE -> no settings.xml
I have set "Options... > +Editor> Leave undo"  ==> closed and started HE -> no settings.xml
"Settings Path" is set to "X:\ <folder with HippoEDIT.exe> \data"

-

I have found that HE still knows the old path (last used before this test)
to the settings.xml (just now, i didn't know where this info is stored *1)
and stores the settings.xml file there in.

EDIT:
*1  => C:\Documents and Settings\username\Local Settings\Temp\hegeneral.tmp
Just delete "hegeneral.tmp" and HE use the own \Data -folder



Have have seen this, because i have renamed my last folder during the test...
.. but while testing this the old folder is created again from beta 550

Hope that helps somehow?  ;D
.
« Last Edit: December 09, 2008, 12:55:44 PM by Stefan »

Offline alex

  • Developer
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2190
  • Karma: +37/-3
    • HippoEDIT
Re: [REQ] Option to set delay before popup
« Reply #7 on: December 09, 2008, 02:05:16 PM »
Yes, I have also noticed that. This is not caused by reinstall. Some internal problems...
Would check.

Offline Stefan

  • Administrator
  • Hero Member
  • *****
  • Posts: 775
  • Karma: +6/-0
Re: [REQ] Option to set delay before popup
« Reply #8 on: December 09, 2008, 10:39:59 PM »
@Alex

Because HE is portable... maybe you want to add current "Settings Path"-Info to About-Dialog? Like with TotalCommander.

Technical Information
File Version:
Build date:
Unicode Support:
Settings Path:

Offline alex

  • Developer
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2190
  • Karma: +37/-3
    • HippoEDIT
Re: [REQ] Option to set delay before popup
« Reply #9 on: December 09, 2008, 10:55:45 PM »
You mean in addition to the information show in Options->General?

Offline Stefan

  • Administrator
  • Hero Member
  • *****
  • Posts: 775
  • Karma: +6/-0
Re: [REQ] Option to set delay before popup
« Reply #10 on: December 10, 2008, 07:59:13 AM »
You mean in addition to the information show in Options->General?
Yes ;D i had should mentioned that i had seen this location too, sorry.
But one have to know where to look to find this.
So when i have searched for that info (which version do i run...and from where is it started) i have take an look in About first.

Technical Information
File Version: 1.4
Build date: 24.12.2008
Unicode Support: yes
Program folder: C:\Program files\HippoEDIT\
Settings Path: C:\Document an......\AddData\HippoEDIT\Data\

Maybe with yellow ToolTip hints to see the full path while hoovering.

Just one of this ideas  ::)
« Last Edit: December 10, 2008, 08:07:53 AM by Stefan »

Offline JJK

  • Registered User
  • Full Member
  • *
  • Posts: 152
  • Karma: +2/-0
Re: [REQ] Option to set delay before popup
« Reply #11 on: December 10, 2008, 09:01:35 AM »
@Stefan
Quote
File Version: 1.4
Build date: 24.12.2008
You anticipate the Christmas gift from Alex ! Cheers.

@Alex and Stefan
I have uninstalled all HE. Then installed 1.33. Settings.xml was created in ../data/ directory. I have modified it in my manner (ie. Hoveringdelay=300 instead of 1000). Then I installed 1.40.552 above 1.33. I kept my settings.xml

Offline alex

  • Developer
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2190
  • Karma: +37/-3
    • HippoEDIT
Re: [REQ] Option to set delay before popup
« Reply #12 on: December 10, 2008, 02:10:24 PM »
It was a bug then settings.xml was not stored. Should work with 522.

Offline JJK

  • Registered User
  • Full Member
  • *
  • Posts: 152
  • Karma: +2/-0
Re: [REQ] Option to set delay before popup
« Reply #13 on: December 10, 2008, 03:03:13 PM »
Quote
Should work with 522
You mean 1.522 ?  ;) But in 1.40.552 it works already !
BTW here (in the latest history) you should replace 551 by 552

Offline alex

  • Developer
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2190
  • Karma: +37/-3
    • HippoEDIT
Re: [REQ] Option to set delay before popup
« Reply #14 on: December 10, 2008, 03:17:52 PM »
Yes. I mean this wa done in 522.
Thanks I have updated version number ;) Copy paste problem ;)