Author Topic: HTML: атрибут span внутри тега помечается как ошибка  (Read 3371 times)

Offline alex

  • Developer
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2190
  • Karma: +37/-3
    • HippoEDIT
Code: HTML5
  1. <col span='2'>

Когда в тег col добавляешь атрибут span, он помечается красным, как будто в синтаксисе ошибка. Этого не должно быть http://htmlbook.ru/html/col/span.

так должен был сделать Reniel
« Last Edit: October 27, 2011, 02:46:15 AM by alex »

Offline alex

  • Developer
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2190
  • Karma: +37/-3
    • HippoEDIT
Это ошибка в схеме, которую можно частично решить.
Что бы не подсвечивалось красным (не закрытый тег), надо добавить в определение scope span разрешение использовать только в начале стилевого блока:
Code: XML
  1.       <Scope open="span" close="span" sent_start="true"/>

проблему с неправильной расскраской (как название едемента а не аттрибута) пока решить нельзя. Схема не позволяет это описать.
Я записал - когда нибудь поправится

Offline Reniel

  • Newbie
  • *
  • Posts: 17
  • Karma: +0/-0
добавил как ты написал выше в схему, теперь возникла следующая проблема уже не с атрибутом, а с тегом span:

Code: HTML5
отображается нормально

Code: HTML5
  1. <span class="color1"></span>
c ошибкой, т.е. когда тегу span добавляешь какой то атрибут, то он его помечает как ошибочный(красным).
« Last Edit: October 27, 2011, 07:42:07 AM by Reniel »

Offline alex

  • Developer
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2190
  • Karma: +37/-3
    • HippoEDIT
Да, правда.
Похоже вариант с sent_start не пройдет.
Я посмотрю, если просто, то поправлю в 1.49. Если не просто, то будет только в 1.50